Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No up and down possible in Rec,Play& Timeshift submenus

Discussion in 'OpenBH General Discussions' started by Alexwilmac, Mar 20, 2021.

  1. wawa16

    wawa16 Vu+ Newbie

    Messages:
    43
    Recent updates for OpenVix 4.5.0.015 & Openatv 7.0 & OBH 4.4 That cause this problem..
     
  2. el bandido

    el bandido Vu+ User

    Messages:
    431
    Some changes to the keymap.xml file were made in the second month of 2021, I don't know if this is your problem, but it may be worth testing or looking into.
    3 lines were added to the keymap.xml around Feb. 8, 2021 as shown in the link:
    https://github.com/BlackHole/enigma...c55156f2c4436ffde7a23be21a4b4261dc1035834f182

    Attached is a file with those 3 lines deleted. You may test it by by unzipping and installing the attached keymap.xml in the '/usr/share/enigma2" folder of the receiver's file system. Keep your old or original keymap.xml file so you can reinstall it if the edited keymap.xml file does not work or causes unwanted issues.
     

    Attached Files:

  3. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,387
    I tried your keymap in OMB (where the issues exists) and it doesn't change anything.
    I believe the problem is, instead, in the pyo files in /usr/lib/enigma2/python/Screens
    As I said, I once succeed at fixing at least one submenu, replacing timeshift.pyo file. But then I gave up.
     
  4. Thomas67

    Thomas67 Vip

    Messages:
    712
    Do the OMB installation also share the Movie/Timeshift location? In the case of having only one storage device in your box your Default Storage device will become the root (Flash) when booting into OMB and a hidden mount /omb is created
    This could be the problem maybe. Even if you can mount the device as /media/hdd it still will have the /omb ref also.

    Digg into your drawers and find a USB memorystick. If not already formated as ext4 use device manager to format the stick or the BH USB Format Wizard. Then mount that as Default storage device and see if the problem is gone?
     
  5. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,387
    Unfortunately, if it wasn't to the fact that this issue:
    a) appeared all of a sudden after of of the first releases of 4.4 (surely after 008) and
    b) to the fact it happens also in flash under some models (like Zero4K, as of my post #11) I might think you are right, my friend. :)
    And, also, for a short time, I managed to fix this bug by "stealing" the two files
    Recordings.pyo
    Timeshift.pyo
    from OATV as it was at the time. Then, also this workaround stopped working after other subsequent updates.
    But the fact itself it worked for a bit, means the issue is within those two files.
    Then if it is due to the sharing of OMB movie location, I don't know.
    There is also to add that (in my case, but I don't think is the case of the other users who have starting reporting the same issue, finally) OMB runs from the internal SDD but, I repeat, in Zero4K it happens also from flash and, even more interesting, without any OMB present in that device!
     
  6. Ev0

    Ev0 Administrator

    Messages:
    2,929
    These are the commits that broke it:
    https://github.com/OpenViX/enigma2/...082697b9e8a76bc21b103b5f94e4d701adb5e7ce957b5
    https://github.com/OpenViX/enigma2/...082697b9e8a76bc21b103b5f94e4d701adb5e7ce957b5

    https://github.com/OpenViX/enigma2/...f29a8c9d683ff89edba9abb179dea2408dd0fd5964f7a
    https://github.com/OpenViX/enigma2/...f29a8c9d683ff89edba9abb179dea2408dd0fd5964f7a

    Feel free to contact the author of these commits (not the person that committed them) on github and ask him to fix them.

    Goodluck
     
    Thomas67 and Alexwilmac like this.
  7. Alexwilmac

    Alexwilmac Vip

    Messages:
    6,387
    Thanks! :) I didn't manage to contact in PM the commits' author but I commented on them.
    Finally... I felt I was talking in the desert ;) Also in the ViX forum, there was no responsible check on this bug.
    Thanks for your discovery.